2008 GIS / Data Management Conference

Migrating from Access to SQL Server


Exercise: Migrating from Access to SQL Server
2Migrate Data from Access to SSE


2Review the Access Application


2Create an Access Data Project (ADP) with the Upsizing Wizard in Access


3Prepare the Database for Upsizing


4Back up the Access File!


4Run the Upsize


5Review the ADP


6Creating a Linked Table Application with the SQL Server Migration Assistant (SSMA) for Access


6Prepare the Database for Migration


7Back up the Access File!


7Run the Migration


8SSMA Interface


9Objects in SSE / Managing the Database with SQL Server Management Studio Express (SSMSE)


9Review the Upsized/Migrated Databases


10Database Properties


11Other Properties


12Differences between Upsizing Wizard and SSMA Conversions


12Creating a String GUID Default Value for Location_ID


13Creating Objects in SQL Server using T-SQL and the SSMSE Interface


13Database


13Add Using T-SQL


13Add Using UI


13Schema


13Add Using T-SQL


14Add Using UI


14User


14Add Using T-SQL


14Add Using UI


14Table


14Add Using T-SQL


14Add Using UI


15Index


15Add Using T-SQL


15Add Using UI


15View


15Add Using T-SQL


16Add Using UI


17Stored Procedure


17Add Using T-SQL


18Add Using UI


18User-defined Function


18Add Using T-SQL


19Add Using UI


19Trigger


19Add Using T-SQL


19Add Using UI


20Conclusion


20Sharing Data


20Enable Network Protocols


20Start the SQL Server Browser Service


20Restart the SQL Server Service


21Connect to the Instructor Computer


21Scripting the Database with the SQL Server Database Publishing Wizard




Migrate Data from Access to SSE

Review the Access Application

This example application is a simple Natural Resource Database Template (NRDT) sample that uses the Front-end Application Builder (FAB) as a front-end.

1. Browse to C:\NPS\MigratingFromAccessToSQLServer\UpsizingToADP\ and open NRDT_FAB.mdb.

2. Click the Open button on the Security Warning if it is displayed.

3. Click the Yes button on the Update Data Table Connections form.

4. Click the Browse button.

5. Select C:\NPS\MigratingFromAccessToSQLServer\UpsizingToADP\BirdVCP_be.mdb and click Open.

6. Click the Update links button.

7. Click OK on the message box.

8. Click the Enter / edit data button on the main menu.

9. Select “Doe_Jane” for the user and “AGFO” for the Park.

10. Click OK.
You can see that the form displays 14 records from AGFO.

11. Click the Close button on the Sample Data Gateway form.

12. Select File > Close from the main Access menu to close the main menu.
13. Hit the F11 key to bring up the database window.

14. Making sure you are on the tables tab in the database window, you can see that there are 12 linked Access tables from BirdVCP_be.mdb.

Create an Access Data Project (ADP) with the Upsizing Wizard in Access
The Upsizing Wizard is a tool in Access that can be used to migrate to SQL Server.  Be aware that since we’re using Access 2003 and SQL Server Express 2005, that the Upsizing Wizard was created before this version of SQL Server was released.
There are three options to choose from when using the Upsizing Wizard: ADP, Linked Tables, or just upsize the data.
Prepare the Database for Upsizing
Hidden items will not be upsized, so we need to make all of our tables visible so that they will get included.  The problem is that all of the hidden tables we have actually live in our front-end, and for a very good reason – they are application settings, version information about the front-end, etc. that only make sense in the front-end.  If we store our application defaults on the server, then everyone edits the same application defaults – that doesn’t make much sense.  However, converting to an ADP means that you can’t save data to local tables in the file.  This is just one bit of manual conversion that will have to occur.  For now, we will upsize these tables with the rest.
1. From the menu at the top of Access, select Tools > Options.

2. On the Options form, with the View tab selected, check the Hidden Objects checkbox and click OK so that hidden items will be displayed.

3. For each of the following tables, right-click the table name on the Tables tab of the database window, select Properties, and uncheck the Hidden checkbox:

· tsys_App_Defaults

· tsys_App_Releases

· tsys_Application_Changes

· tsys_Bug_Reports

· tsys_Link_Files

· tsys_Link_Tables
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Tables that do not have a unique key will not be updateable, so we can fix this by making sure every table has a primary key (PK).
4. Add an autonumber primary key named Default_ID to tsys_App_Defaults.
a. Open tsys_App_Defaults in Design view.

b. Scroll to the bottom of the field list and add a field named Default_ID.

c. In the Data Type column for the new field, select Autonumber.

d. Right-click on the new field and select Primary Key.

e. Save and close the table. 

5. Add an autonumber primary key named Change_ID to tsys_Application_Changes.

6. Close NRDT_FAB.mdb.
7. Open C:\NPS\MigratingFromAccessToSQLServer\UpsizingToADP\BirdVCP_be.mdb.

8. Add a compound primary key to the table xref_Event_Contacts on Event_ID and Contact_ID.
9. Close BirdVCP_be.mdb.
Back up the Access File!
Before running any of these upsizing/migration tools, ALWAYS, ALWAYS, ALWAYS make a backup copy of the file that you are migrating.  If something goes wrong during the upsizing/migration, you can at least have a fresh file to start over with.  Do it now – make a backup copy of NRDT_FAB.mdb.

Run the Upsize
1. Open C:\NPS\MigratingFromAccessToSQLServer\UpsizingToADP\NRDT_FAB.mdb.

2. Select File > Close from the main Access menu to close the main menu.

3. Hit the F11 key to bring up the database window.

4. From the menu at the top of Access, select Tools > Database Utilities > Upsizing Wizard.

5. On the Upsizing Wizard Screen, select Create new database and click the Next button.

6. In the What SQL Server would you like to use for this database? drop-down, type “(local)\SQLEXPRESS”.

7. Check the Use Trusted Connection checkbox to use Windows Authentication.

8. In the What do you want to name your new SQL Server database? text box, type “NRDT_Upsize_ADP” and click the Next button.

9. Click the double right arrow button to select all tables and click the Next button.

10. Under What table attributes do you want to upsize? check the boxes for Indexes, Validation rules, Defaults, and Table relationships and leave the Table relationships option group selected as “Use DRI”.

DRI stands for “Declared Referential Integrity” and works the same way as relationships in Access with primary and foreign keys.  If we selected Use triggers, then SQL Server would run T-SQL code on UPDATE, DELETE, or INSERT for a table to check on related records.

11. In the Add timestamp fields to tables? drop-down, select “Yes, let wizard decide” and click the Next button.

12. Under What application changes do you want to make? select “Create a new Access client/server application”.

13. Do not check the box for Save password and user ID (if you check this box, it will save your password unencrypted in a file) and click Next.

14. Select the option Open the new ADP file and click Finish.

15. Click Open if you get a Security Warning (may happen several times).

Access will go through the upsizing process and when finished, will present an Upsizing Wizard Report to review errors, parameters selected, and what conversions were made for each table and each field in each table.  Note that there is also a Queries section at the end of the report, because when creating an ADP, Access attempts to upsize tables and queries.  Note that the query qfrm_Data_Gateway was upsized to a SQL Server function (because it contains an ORDER BY clause – views in SQL Server cannot contain ORDER BY clauses) and the query qfrm_DataEntry was upsized to a SQL Server view.
16. After you’ve finished reviewing the Upsizing Wizard Report, close it.
Review the ADP
1. Access will open the ADP.  Click Open if any Security Warning windows appear.
2. Click OK on the error message(s) that appear.
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Our Visual Basic for Applications (VBA) code is already broken.  In this case, we had some code that tried to reference a DAO.Recordset (DAO stands for Data Access Objects) object.  ADPs don’t recognize DAO, they expect ADO (ActiveX Data Objects).  If you upsized an application with very little code or with ADO code, you could expect smoother sailing.
3. Hit the F11 key to bring up the database window.

4. Select the Tables tab and open tbl_Events.

Notice the new navigation buttons at the bottom of the table.  In addition to the standard first, previous, next, last, and new record buttons, there are also buttons for cancel query and for setting the maximum number of records to display.
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5. Close tbl_Events.

6. With tbl_Events still selected in the database window, click the Design button at the top of the database window.

Note that SQL Server 2005 doesn’t support design changes from Access 2003.  If you use SQL Server 2000, you could make design changes from your Access 2003 Data Project.

7. Click OK on the warning messages.

You can view some of the properties of the SQL Server tables, but you can’t save any changes to those tables.

8. Close the table.

9. Select the Forms tab on the database window and open frm_Locations.

The Locations form is displaying data drawn directly from SQL Server now.

10. Close the ADP.

Creating a Linked Table Application with the SQL Server Migration Assistant (SSMA) for Access
The SSMA is a stand-alone tool developed by Microsoft for moving from Access databases to SQL Server databases (there are also SSMA tools for migrating from Oracle or Sybase).  It is recommended over the Upsizing Wizard in Access for moving to a linked table application or when you are simply looking to migrate tables and queries to SQL Server.  If you would like to create an ADP, you’ll still have to use the Upsizing Wizard.
Prepare the Database for Migration
Tables that do not have a unique key will cause errors, so we can fix this by making sure every table has a primary key (PK).

1. Open C:\NPS\MigratingFromAccessToSQLServer\SSMA\BirdVCP_be.mdb.

2. Add a compound primary key to the table xref_Event_Contacts on Event_ID and Contact_ID.
3. Close xref_Event_Contacts.

The SSMA also does not deal well with the Format() function that is in the default value property wherever we have a string GUID (globally unique identifier) field.  We’ll replace that with some code in SQL Server later.

4. Delete the default value for each of the following fields:

· tbl_BirdVCP_Birds.BirdVCP_ID

· tbl_Data_Locations.Data_Location_ID

· tbl_Db_Meta.Db_Meta_ID

· tbl_Event_Details.Event_ID

· tbl_Event_Group.Event_Group_ID

· tbl_Events.Event_ID

· tbl_Field_Data.Data_ID

· tbl_Locations.Location_ID

· tbl_Sites.Site_ID

· tlu_Contacts.Contact_ID

5. Close BirdVCP_be.mdb.

We also need to make sure that the front-end is linked properly to the back-end file containing the tables we wish to migrate.

6. Open C:\NPS\MigratingFromAccessToSQLServer\SSMA\NRDT_FAB.mdb.

7. Click the Open button on the Security Warning if it is displayed.

8. Click the Yes button on the Update Data Table Connections form.

9. Click the Browse button.

10. Select C:\NPS\MigratingFromAccessToSQLServer\SSMA\BirdVCP_be and click Open.

11. Click the Update links button.

12. Click OK on the message box.
13. Close the front-end.

Back up the Access File!
Before running any of these upsizing/migration tools, ALWAYS, ALWAYS, ALWAYS make a backup copy of the file that you are migrating.  If something goes wrong during the upsizing/migration, you can at least have a fresh file to start over with.  Do it now – make a backup copy of NRDT_FAB.mdb.
Run the Migration
1. Start SSMA by clicking the Windows Start button and selecting All Programs > Microsoft SQL Server Migration Assistant for Access > Microsoft SQL Server Migration Assistant for Access.

2. On the License Management window, click the hyperlink.

3. Follow the instructions on the screen to register the SSMA.
4. Save the file to the directory specified on the License Management window and click OK to continue.

The SSMA has an optional wizard interface that leads you through the steps for migrating your Access database to SQL Server.  We’ll take advantage of that wizard.

5. Click Next on the Migration Wizard welcome screen.
6. Change the Name of the migration to “BirdVCP_SSMA”.

7. Change the Location to “C:\NPS” and click Next.

8.  Click the Add Databases button and select C:\NPS\MigratingFromAccessToSQLServer\SSMA\NRDT_FAB.mdb and click Open, then click Next.
9. Once the page has finished loading the table information, expand the NRDT_FAB node and notice that only tables will be migrated by default.
10. Check the checkbox for Queries to include them in the migration.

We don’t want to upsize our local front-end administrative tables, since they should be unique to each copy of the front-end.

11. Expand the Tables node and uncheck the checkboxes for any table that starts with “tsys” and click Next.
12. In the Connect to SQL Server window of the Migration Wizard, enter “(local)\SQLEXPRESS” for the Server name.
13. In the Database textbox, enter “BirdVCP_SSMA” and click Next.

14. When prompted, click Yes to create the database.

15. On the Link Tables page of the wizard, check the Link Tables checkbox and click Next.

16. Once the Migration Status page finishes updating, read the information on the page and click the hyperlinks where there were warning or informational messages to learn more about the migration and potential problems we may encounter.
17. Click Close on the Migration Wizard form.

If you received any errors, you could read the error message, go back and make changes to your Access database and re-run the migration.  That’s how I discovered the problems that we fixed in the “Prepare the Database for Migration” section of this document.  In some cases, you will be able to run the migration for just the tables that failed and in other cases you will have to re-run the entire migration.

SSMA Interface
With the Migration Wizard window closed, you can see the interface for SSMA.  There are all kinds of settings that can be modified for your migrations.

1. Click Tools > Default Project Settings.

Have a look at the default project settings for SSMA.
2. Select Migration from the menu on the left of the Default Project Settings window.

Look at the Dates Correction section and notice that SSMA is handling dates before 1/1/1753 by replacing them with 1/1/1753.  Unless you start digging around in the settings for SSMA, you might be unaware of these “corrections” to your data.
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3. Select Type Mapping from the menu on the left of the Default Project Settings window and note how SSMA converts Access data types to SQL Server data types.

4. Click Cancel on the Default Project Settings window.

5. Close the SSMA and save changes to your project when prompted.

6. Check the checkbox for NRDT_FAB and click Save when prompted to save metadata.

Objects in SSE / Managing the Database with SQL Server Management Studio Express (SSMSE)
Review the Upsized/Migrated Databases
Now that we’ve upsized and migrated some Access tables to SQL Server, let’s look at the SQL Server databases that were created.  In order to do this, we will use SQL Server Management Studio Express (SSMSE).
1. Open SSMSE by clicking the Windows Start button and selecting All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio Express.

2. When the Connect to Server window appears, make sure that Server type is “Database Engine” and Authentication is Windows Authentication then click the Connect button.

Initially, you are presented with an Object Explorer in the left pane that shows all of the objects in the SQL Server instances that you have connected and a Summary window in the right pane that again shows all of the objects in the currently select SQL Server instance.
Database Properties

1. In the Object Explorer pane on the left, expand the Databases node to show all of the databases in the current instance of SQL Server.


You should see three databases: System Databases, BirdVCP_SSMA, and NRDT_Upsize_ADP.

2. Right-click on the database NRDT_Upsize_ADP and select Properties from the menu.

On the General page of the database properties, you can see the size of the database, available space in the database, and the collation settings.

3. Select the Files page and you can see the files that make up the database – the data file and the log file.

4. Select the Options page and you can see a host of settings that can be changed.

One of the most important settings on this page is the Recovery model setting.  There are three options: Full, Bulk-logged, and Simple (default).  Full logged means that log files can grow quite large, but that it is possible to recover data to a point in time.  Bulk-logged is intended as an adjunct to Full recovery that can speed up bulk operations (imports, re-indexing, etc.).  Simple keeps a smaller log, but is only recoverable to the last backup, so backups should be more frequent using this model.
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5. Click the Cancel button to close the database properties window.

Other Properties

1. Expand the NRDT_Upsize_ADP node and then expand the Tables node.
2. Expand the node for dbo.tlu_Contacts and then expand the Constraints node.

3. Right-click the constraint under the Constraints node and then select Script Constraint as > CREATE To > New Query Editor Window.

Note that the default value of “USA” for the Country field in the table tlu_Contacts has been made into a constraint in SQL Server

4. Close the Query Editor Window.

5. Expand the Indexes node for dbo.tlu_Contacts.

Note that SQL Server has reproduced the primary key, state_code, and zip_code indexes from Access.

Differences between Upsizing Wizard and SSMA Conversions
1. Expand the Columns node for dbo.tlu_Contacts.

Note that SQL Server has assigned the data type ntext to the column Contact_Notes.  The SQL Server data types text, ntext, and image are deprecated and won’t be supported in a future version of SQL Server (note that they appear to be supported still in SQL Server 2008).  They are replaced by nvarchar(max), varchar(max), and varbinary(max), respectively.  This is another peril of using a tool (Upsizing Wizard) that was created before the current version of SQL Server.

2. Expand the database node for BirdVCP_SSMA and get down to the Columns node for dbo.tlu_Contacts.

Note that the database created by the SSMA used nvarchar(max) for the Contact_Notes column.

Creating a String GUID Default Value for Location_ID

We deleted the default values for all of our string GUID fields before we used the migration tool to move our data from Access to SQL Server because SQL Server doesn’t support the Format() function from Access.  Now we can create a new default value that is a true string GUID on our Location_ID column in the table tbl_Locations.
1. Click the New Query button on the toolbar at the top of SSMSE to get a new query window.

2. In the new query window, type the following T-SQL statement:

ALTER TABLE BirdVCP_SSMA.dbo.tbl_Locations

ADD CONSTRAINT DF_Location_ID

DEFAULT '{' + CAST(NEWID() AS varchar(50)) + '}' FOR Location_ID;

3. Click the Execute button on the toolbar or hit the F5 key to run the T-SQL statement.

The NEWID function creates a unique value of type uniqueidentifier, which is a GUID.  The CAST function converts the uniqueidentifier to a character string so that it can be inserted into our Location_ID field.
4. Click the New Query button to get another query window.

5. In the new query window, type and run the following T-SQL statement:

INSERT INTO BirdVCP_SSMA.dbo.tbl_Locations (X_Coord,Y_Coord)

VALUES (30,30)
GO
SELECT * FROM BirdVCP_SSMA.dbo.tbl_Locations
This T-SQL statement inserts a new record into tbl_Locations and then queries all the values from the table.  You can see that the record that was added with x and y coordinates of 30 has a string GUID value for Location_ID, just like the records we brought in from Access.

Creating Objects in SQL Server using T-SQL and the SSMSE Interface

SQL Server Management Studio Express presents a couple of options when creating, modifying, and deleting objects in SQL Server: T-SQL statements or using the SSMSE interface.  We will explore using both methods to create some common database objects.
Database
Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement (you may have to right-click on the Databases node and select Refresh to see the database after creating it):

CREATE DATABASE TSQL_DB

ON (NAME = 'TSQL_DB',

    FILENAME = 'C:\NPS\TSQL_DB.mdf',

    SIZE = 20 MB,

    FILEGROWTH = 0)

LOG

ON (NAME = 'TSQL_DB_Log',

    FILENAME = 'C:\NPS\TSQL_DB_Log.ldf',

    SIZE = 5 MB,

          FILEGROWTH = 0)
Add Using UI

1. Right-click on the Databases node in the SSMSE interface and select New Database.

2. In the Database name box, enter “UI_DB”.

3. In the Initial Size (MB) column, enter 20 for the Data row and 5 for the Log row.

4. Click the builder button in the Autogrowth column for the Data row, uncheck the Enable Autogrowth checkbox, and click OK.
5. Do the same for the Log row.
6. Click the builder button in the Path column for the Data row and select C:\NPS.

7. Do the same for the log file.

8. Click OK on the New Database window to create the database.

Schema

Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE TSQL_DB

GO

CREATE SCHEMA DataManagementStaff
Add Using UI

1. Expand the Database node for UI_DB.

2. Expand the Security node.

3. Right-click on Schemas and select New Schema.

4. Name the schema “Cultural” and click OK.
User

Since the lab computers aren’t on the NPS domain, we won’t be able to authenticate any users we try to create (Windows Authentication was selected when this instance of SSE was installed).  Instead of actually adding users, we’ll just look at the syntax for adding users.
Add Using T-SQL
USE TSQL_DB

GO

CREATE USER [NPS\Margaret Beer]

(optional line below if we wish to assign the user to a particular schema)

WITH DEFAULT_SCHEMA = DataManagementStaff
Add Using UI

· Right-click on Users under the Security node for the database UI_DB and select New User.

· Enter “NPS\sdk” for User name and for Login name and click OK.
Table

Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE TSQL_DB

GO

CREATE TABLE DataManagementStaff.Application

(AppID int IDENTITY PRIMARY KEY NOT NULL,

 CreatedDate datetime NOT NULL,

 AppName varchar(50) NOT NULL,

 Notes varchar(max) NULL)

This statement creates a table named “Application” in the DataManagementStaff schema that has fields named AppID, CreatedDate, AppName, and Notes.  The IDENTITY keyword you see is analogous to an Autonumber from Access.  The only field that will accept NULL values is the Notes field.
Add Using UI

1. Right-click on Tables under the UI_DB Database node and select New Table.

2. Enter the following:

	Column Name
	Data Type
	Allow Nulls
	Column properties

	ArtifactID
	int
	No
	Identity Specification - (Is Identity) = Yes

	ArtifactName
	varchar(50)
	No
	None

	FoundDate
	datetime
	No
	None

	Notes
	varchar(max)
	Yes
	None


3. In the Properties window on the right of SSMSE, type “Artifact” in the (Name) box and type “Cultural” in the Schema box.

4. Close the table designer view and when prompted, save the table.
Index

Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE TSQL_DB

GO

CREATE UNIQUE NONCLUSTERED INDEX idx_AppName

ON DataManagementStaff.Application (AppName ASC)
Add Using UI

1. Expand the node for the table Cultural.Artifact in the database UI_DB.

2. Right-click on the Indexes node and select New Index.

3. Type “idx_ArtifactName” in the Index name box.
4. Check the checkbox for Unique.

5. Click the Add… button.

6. Check the checkbox for the ArtifactName column and click OK.

7. Click the OK button on the New Index window.

View

We will use one of our migrated databases for creating views so that we can see records.
Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE NRDT_Upsize_ADP
GO

CREATE VIEW vSHEN_Events

AS

SELECT EG.Event_Group_Name AS EventGroupName,E.Start_Date AS EventDate,L.Loc_Name AS LocationName

FROM tbl_Locations L


INNER JOIN tbl_Events E


ON L.Location_ID = E.Location_ID


INNER JOIN tbl_Event_Group EG


ON E.Event_Group_ID = EG.Event_Group_ID

WHERE L.Unit_Code = 'SHEN'

2. Expand the Views node for the Database BirdVCP_SSMA, right-click on dbo.vSHEN_Events, and select Open View.
Using the View in the ADP

1. Open our ADP at C:\NPS\MigratingFromAccessToSQLServer\UpsizingToADP\NRDT_FABCS.adp.

2. Click OK on any error messages and hit F11 to get the database window.

3. Select the Queries tab.

You should be able to see the new view, vSHEN_Events.  Adding the view to our upsized ADP database made it available in the ADP.

4. Close the ADP.

Add Using UI
The user-interface for view creation in SSMSE should be familiar to anyone who has created a query in Access.

1. Right-click on the Views node for BirdVCP_SSMA and select New View.

2. Select tbl_Event_Group, then hold down the Ctrl key and select tbl_Events and tbl_Locations and then click the Add button.

3. Click the Close button on the Add Table window.

4. In the upper part of the window where the tables are displayed, check the checkboxes next to the following columns in this order:

a. tbl_Event_Group.Event_Group_Name

b. tbl_Events.Start_Date

c. tbl_Locations.Loc_Name

d. tbl_Locations.Unit_Code

5. In the lower part of the window where the query grid is displayed, enter the following in the Alias column working from top to bottom:

a. EventGroupName

b. EventDate

c. LocationName

6. For the Filter column, enter “SHEN” for the Unit_Code row.
7. Click the Save button.

8. In the Choose Name box, enter “vSHEN_Events_UI” and click OK.

9. In the Views node, right-click on dbo.vSHEN_Events_UI, and select Open View.

Using the View in the Linked MDB

There are a couple of options open to us to get the data from the vSHEN_Events_UI view: recreate it as a select query in our Access MDB, or use a pass-through query to return its results in a SELECT statement that executes directly on SQL Server.  Pass-through queries are used to send commands directly to an ODBC database server.  By using an SQL pass-through query, you work directly with the server tables instead of having the Jet database engine process the data.  The following steps lead through creating a pass-through query:
1. Open the MDB at C:\NPS\MigratingFromAccessToSQLServer\SSMA\NRDT_FAB.mdb.

2. Close any error messages and click No if asked if you wish to re-link.

3. Hit the F11 key to get the database window.

4. Select the Queries tab and click the New button on the database window.

5. Without adding tables or queries, click Close in the Show Table dialog box.

6. On the Query menu, point to SQL Specific, and then click Pass-Through.

7. On the toolbar, click Properties to display the query property sheet if it’s not already showing.

8. In the query property sheet, set the ODBCConnectStr property to “ODBC;DRIVER=SQL Server;SERVER=(local)\SQLEXPRESS;DATABASE=BirdVCP_SSMA”

9. In the SQL Pass-Through Query window, type the following T-SQL statement:

SELECT *

FROM vSHEN_Events_UI
10. Run the query.
Stored Procedure

Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE TSQL_DB

GO

CREATE PROC DataManagementStaff.AddApplication


@CreatedDate datetime, @AppName varchar(50),


@Notes varchar(max), @AppID int OUTPUT

AS

INSERT INTO DataManagementStaff.Application (CreatedDate,


AppName,Notes)

VALUES (@CreatedDate, @AppName, @Notes)

SET @AppID = SCOPE_IDENTITY()
This stored procedure takes parameters and adds a record to our Application table and then returns the AppID value of the record that was added.

2. Open a New Query window and type in and execute the following T-SQL statement to run the stored procedure, return the AppID value of the new record, and return the whole new record:

USE TSQL_DB

GO

DECLARE @AppID int, @result int

EXEC @result = DataManagementStaff.AddApplication '1-Apr-2007','Species 2.0','Best application... ever.', @AppID OUTPUT

SELECT @AppID
SELECT * FROM DataManagementStaff.Application
Add Using UI

1. Expand the Programmability node for the UI_DB database.

2. Right-click on the Stored Procedures node and select New Stored Procedure.

This generates a template for a stored procedure that you can fill in.

3. Hit Ctrl-Shift-M to open the Specify Values for Template Parameters form.

On this form, you can enter new values for the parameters, and those values will get added to the stored procedure.

4. Click OK.

There’s still a lot of T-SQL left to be written if you compare what the template leaves us with to the T-SQL from the first stored procedure we did.  The template is good for getting started, but you will still have to know some T-SQL to get anything done.

User-defined Function

Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE BirdVCP_SSMA

GO

CREATE FUNCTION LocEventCount (@LocationID varchar(50)) RETURNS int

AS

BEGIN


DECLARE @ret int


SELECT @ret = COUNT(*)


FROM tbl_Events

WHERE Location_ID = @LocationID


RETURN @ret

END

GO

SELECT Loc_Name, dbo.LocEventCount(Location_ID)

FROM tbl_Locations
This scalar function takes a Location_ID as a parameter and counts how many events exist for that location in tbl_Events.
Add Using UI

1. Expand the Programmability node for the BirdVCP_SSMA database.

2. Expand the Functions node and right-click on the Scalar-valued Functions node and select New Scalar-valued Function.

As with stored procedures, this generates a template for a scalar-valued function that you can fill in, but you still have to use T-SQL to do most of the work.
Trigger

Add Using T-SQL
1. Open a New Query window and type in and execute the following T-SQL statement:

USE BirdVCP_SSMA

GO

CREATE TRIGGER uLocations ON tbl_Locations

AFTER UPDATE AS

BEGIN


SET NOCOUNT ON;


UPDATE tbl_Locations


SET Updated_Date = GETDATE()


FROM inserted


WHERE inserted.Location_ID = tbl_Locations.Location_ID

END

GO

UPDATE tbl_Locations

SET X_Coord = 10

WHERE X_Coord IS NULL

GO

SELECT X_Coord, Updated_Date FROM tbl_Locations

The T-SQL creates a trigger that will update the Updated_Date field in tbl_Locations when a record in tbl_Locations is modified.  We also added T-SQL to test the trigger by updating a record and returning the X_Coord and Updated_Date fields from tbl_Locations.
Add Using UI

1. Right-click on the Triggers node for tbl_Locations under the BirdVCP_SSMA database and select New Trigger.

This generates a template for a trigger that you can fill in, but the main part of the program must be written in T-SQL.
Conclusion

SQL Server Management Studio Express provides tools for accomplishing many object creation tasks, but it still pays to get to learn T-SQL if you’re going to be working with SQL Server, especially if you plan to use the programmability objects (stored procedures, user-defined functions, triggers, etc.).
Sharing Data

SQL Server starts out “locked down” by default, so that your database will be less vulnerable to attack.  In order to share SQL Server data with others on the network, we need to change some settings to allow remote connections.
Enable Network Protocols

The first step is to enable network protocols.  With SQL Server Express, the network protocols are TCP/IP or Named Pipes.  TCP/IP is the preferred option because it requires that fewer ports be opened on your firewall.  Named pipes may have to be used to support legacy applications, however.  Network protocols can be enabled with the SQL Server Configuration Manager.

1. On the Windows Start Menu, select All Programs > Microsoft SQL Server 2005 > Configuration Tools > SQL Server Configuration Manager.

2. Expand the node for SQL Server 2005 Network Configuration in the left pane.
3. Select Protocols for SQLEXPRESS in the left pane.

4. Right-click on TCP/IP in the right pane and select Enable.

Start the SQL Server Browser Service

The SQL Server Browser Service facilitates the connection of remote computers to a SQL Server instance.

1. In the SQL Server Configuration Manager, select SQL Server 2005 Services in the left pane.

2. Right-click on SQL Server Browser in the right pane and select Properties.

3. Select the Service tab on the SQL Server Browser Properties form.

4. Under Start Mode, select Automatic and click OK to close the form.

5. Right-click again on SQL Server Browser and select Start.

Restart the SQL Server Service

It is good practice to restart the SQL Server service following configuration changes such as these.

1. In the SQL Server Configuration Manager, with SQL Server 2005 Services selected in the left pane, right-click on SQL Server (SQLEXPRESS) and select Restart.

2. Close the SQL Server Configuration Manager.

Connect to the Instructor Computer

1. In SSMSE, select File > Connect Object Explorer.

2. Enter the computer name given to you by the instructor in the Server name box and click Connect.

You should be able to see the SQL Server Express instance on the instructor’s computer and run queries against the databases that you see there.

Scripting the Database with the SQL Server Database Publishing Wizard

The Database Publishing Wizard enables the deployment of SQL Server databases into a shared hosting environment.  There are two options for deploying databases with this tool: generating a SQL script file that can be run in a script execution window or connecting to a web service and directly creating objects on a specified hosted database.  We will try generating the SQL script file.
1. On the Windows Start Menu, select All Programs > Microsoft SQL Server Database Publishing Wizard > Database Publishing Wizard.

2. Click Next on the Database Publishing Wizard form.

3. Enter “localhost\SQLEXPRESS” for the Server and select the Use Windows Authentication option and click Next.

4. Select BirdVCP_SSMA from the list of databases, make sure the Script all objects in the selected database checkbox is checked, and click Next.
5. With the Script to file option selected, enter “C:\NPS\BirdVCP_SSMA.sql” for the File name and click Next.

6. Review the publishing options and click Next.

7. Click Finish to script the database.

8. Click Close once the publishing is complete.

9. Double-click on the file C:\NPS\BirdVCP_SSMA.sql to open the script in SSMSE.

Have a look at the script that was generated by the Database Publishing Wizard.  It checks for the existence of the objects to start with and drops (deletes) them as necessary, then creates new objects, and in the case of tables, populates them with records.  Note that the script does not create the database.  You must do that first on the target SQL Server instance and then run the script in the context of that database.
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